# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"```([\w\W]*?)```"
test_str = ("###Sample Input\n"
"```\n"
"3\n"
"100 400 1000 1200\n"
"100 450 1000 1350\n"
"150 400 1200 1200\n"
"```")
matches = re.search(regex, test_str)
if matches:
print ("Match was found at {start}-{end}: {match}".format(start = matches.start(), end = matches.end(), match = matches.group()))
for groupNum in range(0, len(matches.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = matches.start(groupNum), end = matches.end(groupNum), group = matches.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.