package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?i)a[^ab\s]?x[^ab\s]?b`)
var str = `AyB AXB AxB blabla`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}