$re = '/a[^ab\s]?x[^ab\s]?b/i';
$str = 'AyB AXB AxB blabla';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);