const regex = /a[^ab\s]?x[^ab\s]?b/i;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('a[^ab\\s]?x[^ab\\s]?b', 'i')
const str = `AyB AXB AxB blabla`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}