$re = '/\b(?!zz)(?:(?!zz\b)\w)+zz(?:(?!zz\b)\w)+\b/m';
$str = 'lorem ipsum buzz mezzo mix zztop but this is all';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);