re = /\b(?!zz)(?:(?!zz\b)\w)+zz(?:(?!zz\b)\w)+\b/m
str = 'lorem ipsum buzz mezzo mix zztop but this is all'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end