#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "[&?]tags=([^&\n-]*(?:-[^&\n-]+)*)(?:--(\d+))?"
Local $sString = "http://localhost:30001/catalog/search?tags=bed-green-big-33-22-ancient-5--2" & @CRLF & _
"http://localhost:30001/catalog/search?tags=bed-green-big-33-22-ancient-5" & @CRLF & _
"http://localhost:30001/catalog/search?more1=eee&tags=bed-green-big-33-22-ancient-5--4&gh=1"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")