import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "[&?]tags=([^&\\n-]*(?:-[^&\\n-]+)*)(?:--(\\d+))?";
final String string = "http://localhost:30001/catalog/search?tags=bed-green-big-33-22-ancient-5--2\n"
+ "http://localhost:30001/catalog/search?tags=bed-green-big-33-22-ancient-5\n"
+ "http://localhost:30001/catalog/search?more1=eee&tags=bed-green-big-33-22-ancient-5--4&gh=1";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}