#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(- [\s\S]+?)(?:\n\n(?=\n))|(- [\s\S]+?)(?:\n\n(?=- ))"
Local $sString = "- sometext" & @CRLF & _
"" & @CRLF & _
"- sometext" & @CRLF & _
"followingText" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"- sometext" & @CRLF & _
"" & @CRLF & _
"- sometext" & @CRLF & _
"- sometext"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")