re = /(- [\s\S]+?)(?:\n\n(?=\n))|(- [\s\S]+?)(?:\n\n(?=- ))/
str = '- sometext
- sometext
followingText
- sometext
- sometext
- sometext'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end