using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(- [\s\S]+?)(?:\n\n(?=\n))|(- [\s\S]+?)(?:\n\n(?=- ))";
string input = @"- sometext
- sometext
followingText
- sometext
- sometext
- sometext";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}