const regex = /(?<=[a-z])(?=[A-Z])/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<=[a-z])(?=[A-Z])', 'g')
const str = `AccountUserID
User_ID`;
const subst = ` `;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);