import Foundation
let pattern = #"(?<=[a-z])(?=[A-Z])"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
AccountUserID
User_ID
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #" "#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)