$re = '/(?<=[a-z])(?=[A-Z])/';
$str = 'AccountUserID
User_ID';
$subst = " ";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;