# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?!^[+-])\D+//gm;t' <<< "-------5548481818fgh7hf8ghf----fgh54f4578"