re = /(?!^[+-])\D+/m
str = '-------5548481818fgh7hf8ghf----fgh54f4578'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result