$re = '/(?!^[+-])\D+/m';
$str = '-------5548481818fgh7hf8ghf----fgh54f4578';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;