re = /(?i)(?:(?<=^|\s)(?=\S)|(?<=\S|^)(?=\s)){0}(?:(?<=\S)(?=\s|$)|(?<=\s)(?=\S|$))/
str = 'ally can be chaallnged {ALL} tested all'
# Print the match result
str.match(re) do |match|
puts match.to_s
end