#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(\w+)(\w+)\2\1"
Local $sString = "catdogdogcat " & @CRLF & _
"redbluebluered " & @CRLF & _
"noyesyesno" & @CRLF & _
"catdogcat" & @CRLF & _
"redbluered" & @CRLF & _
"yesnoyes"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")