re = /(\w+)(\w+)\2\1/m
str = 'catdogdogcat
redbluebluered
noyesyesno
catdogcat
redbluered
yesnoyes'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end