$re = '/(\w+)(\w+)\2\1/m';
$str = 'catdogdogcat
redbluebluered
noyesyesno
catdogcat
redbluered
yesnoyes';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);