$re = '/^30([0-4][0-9a-f])(02([0-2][0-9a-f])(00)?[a-f0-9]{2,64})(02([0-2][0-9a-f])(00)?[a-f0-9]{2,64})(01|02|03|81|82|83)?$/i';
$str = '304402200e2244c8966e5b1a150f49d0f6bac978a9cfa1c4b32b4cf783c9f7c93be4bc6b022077018e8d6da02ec60f93b3e936fd283aa87beab1c373839616d1ad5a9bc4dcfb';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);