import re
regex = re.compile(r"^30([0-4][0-9a-f])(02([0-2][0-9a-f])(00)?[a-f0-9]{2,64})(02([0-2][0-9a-f])(00)?[a-f0-9]{2,64})(01|02|03|81|82|83)?$", flags=re.IGNORECASE)
test_str = "304402200e2244c8966e5b1a150f49d0f6bac978a9cfa1c4b32b4cf783c9f7c93be4bc6b022077018e8d6da02ec60f93b3e936fd283aa87beab1c373839616d1ad5a9bc4dcfb"
match = regex.search(test_str)
if match:
print(f"Match was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")