import Foundation
let pattern = #"^30([0-4][0-9a-f])(02([0-2][0-9a-f])(00)?[a-f0-9]{2,64})(02([0-2][0-9a-f])(00)?[a-f0-9]{2,64})(01|02|03|81|82|83)?$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .caseInsensitive)
let testString = #"304402200e2244c8966e5b1a150f49d0f6bac978a9cfa1c4b32b4cf783c9f7c93be4bc6b022077018e8d6da02ec60f93b3e936fd283aa87beab1c373839616d1ad5a9bc4dcfb"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}