use strict;
my $str = 'asdsa,sad,,sad,sa,d,as,d,asd,asd
,12121,2,1,2,1,2,1,2
asd,asd,,sad,';
my $regex = qr/(?!,[^,]*,),|(^[^,]*?),/mp;
my $subst = '$1*';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";