import Foundation
let pattern = #"(?!,[^,]*,),|(^[^,]*?),"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
asdsa,sad,,sad,sa,d,as,d,asd,asd
,12121,2,1,2,1,2,1,2
asd,asd,,sad,
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1*"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)