$re = '/(?!,[^,]*,),|(^[^,]*?),/m';
$str = 'asdsa,sad,,sad,sa,d,as,d,asd,asd
,12121,2,1,2,1,2,1,2
asd,asd,,sad,';
$subst = "$1*";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;