use strict;
my $str = 'example.com/My-Awesome-Product
example.com/Other-Page
asdsads/asdas-asdsa-sadsad-asda
';
my $regex = qr/^(?![^-]*-[^-]*$)^(.*\/)/mp;
my $subst = '$1Product/';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";