re = /^(?![^-]*-[^-]*$)^(.*\/)/m
str = 'example.com/My-Awesome-Product
example.com/Other-Page
asdsads/asdas-asdsa-sadsad-asda
'
subst = '$1Product/'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result