$re = '/^(?![^-]*-[^-]*$)^(.*\/)/m';
$str = 'example.com/My-Awesome-Product
example.com/Other-Page
asdsads/asdas-asdsa-sadsad-asda
';
$subst = "$1Product/";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;