#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(one|two|three);?(?!\1)(one|two|three);?(?!\2)(one|two|three)"
Local $sString = "one;two;three" & @CRLF & _
"two;one;three" & @CRLF & _
"three;two;one" & @CRLF & _
"one;one;two" & @CRLF & _
"three;one;two" & @CRLF & _
"onetwothree" & @CRLF & _
"two;one;one"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")