const regex = /(one|two|three);?(?!\1)(one|two|three);?(?!\2)(one|two|three)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(one|two|three);?(?!\\1)(one|two|three);?(?!\\2)(one|two|three)', 'gm')
const str = `one;two;three
two;one;three
three;two;one
one;one;two
three;one;two
onetwothree
two;one;one`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}