import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(Vwo|Havo) met profiel (.*?)\\.?$";
final String string = "Vwo met profiel EM (met Wiskunde B, Natuurkunde & Scheikunde), CM (met Wiskunde B, Natuurkunde & Scheikunde), NG (met Wiskunde B & Natuurkunde), NT.\n"
+ "Vwo met profiel EM (met Scheikunde & Biologie), CM (met Scheikunde & Biologie), NG, NT.\n"
+ "Vwo met profiel EM (met Natuurkunde & Scheikunde), CM (met (Wiskunde A of Wiskunde B) & Natuurkunde & Scheikunde), NG (met Natuurkunde), NT.\n"
+ "Havo met profiel EM, CM (met Economie of M&O), NG (met Economie, een tweede vreemde taal of M&O), NT (met Economie, een tweede vreemde taal of M&O).\n"
+ "Havo met profiel EM, CM (met Economie & (Wiskunde A of Wiskunde B) of M&O en (Wiskunde A of Wiskunde B)), NG (met Economie of M&O), NT (met Economie of M&O).\n"
+ "Havo met profiel EM, CM (met Economie, M&O of Maatschappijwetenschappen), NG (met Economie of M&O), NT (met Economie of M&O).\n"
+ "Vwo met profiel EM, CM (met Economie, M&O of Maatschappijwetenschappen), NG (met Economie of M&O), NT (met Economie of M&O).\n"
+ "Havo met profiel EM, CM (met Wiskunde A of Wiskunde B), NG, NT.\n"
+ "Havo met profiel EM, CM (met Economie & (Wiskunde A of Wiskunde B) of M&O en (Wiskunde A of Wiskunde B)), NG (met Economie of M&O), NT.";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}