re = /^(Vwo|Havo) met profiel (.*?)\.?$/m
str = 'Vwo met profiel EM (met Wiskunde B, Natuurkunde & Scheikunde), CM (met Wiskunde B, Natuurkunde & Scheikunde), NG (met Wiskunde B & Natuurkunde), NT.
Vwo met profiel EM (met Scheikunde & Biologie), CM (met Scheikunde & Biologie), NG, NT.
Vwo met profiel EM (met Natuurkunde & Scheikunde), CM (met (Wiskunde A of Wiskunde B) & Natuurkunde & Scheikunde), NG (met Natuurkunde), NT.
Havo met profiel EM, CM (met Economie of M&O), NG (met Economie, een tweede vreemde taal of M&O), NT (met Economie, een tweede vreemde taal of M&O).
Havo met profiel EM, CM (met Economie & (Wiskunde A of Wiskunde B) of M&O en (Wiskunde A of Wiskunde B)), NG (met Economie of M&O), NT (met Economie of M&O).
Havo met profiel EM, CM (met Economie, M&O of Maatschappijwetenschappen), NG (met Economie of M&O), NT (met Economie of M&O).
Vwo met profiel EM, CM (met Economie, M&O of Maatschappijwetenschappen), NG (met Economie of M&O), NT (met Economie of M&O).
Havo met profiel EM, CM (met Wiskunde A of Wiskunde B), NG, NT.
Havo met profiel EM, CM (met Economie & (Wiskunde A of Wiskunde B) of M&O en (Wiskunde A of Wiskunde B)), NG (met Economie of M&O), NT.'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end