using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?=[A-Z]{1,4}[0-9]{1,4}).{2,5}";
string input = @"AAAA1 AAA11 AA111AA A1111 AAAAA AAAA1111";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}