$re = '/(?=[A-Z]{1,4}[0-9]{1,4}).{2,5}/';
$str = 'AAAA1 AAA11 AA111AA A1111 AAAAA AAAA1111';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);