const regex = /(?=[A-Z]{1,4}[0-9]{1,4}).{2,5}/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?=[A-Z]{1,4}[0-9]{1,4}).{2,5}', 'g')
const str = `AAAA1 AAA11 AA111AA A1111 AAAAA AAAA1111`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}