$re = '`([0-9a-fA-F]{8})([0-9a-fA-F]{4})([0-9a-fA-F]{4})([0-9a-fA-F]{4})([0-9a-fA-F]+)`m';
$str = '0a1f0a1f0a1f0a1f0a1f0a1f0a1f 0a1f0a1f0a1f0a1f0a1f0a1f0a1f';
$subst = "$1-$2-$3-$4-$5";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;