import re
regex = re.compile(r"([0-9a-fA-F]{8})([0-9a-fA-F]{4})([0-9a-fA-F]{4})([0-9a-fA-F]{4})([0-9a-fA-F]+)", flags=re.MULTILINE)
test_str = "0a1f0a1f0a1f0a1f0a1f0a1f0a1f 0a1f0a1f0a1f0a1f0a1f0a1f0a1f"
subst = "$1-$2-$3-$4-$5"
result = regex.sub(subst, test_str)
if result:
print(result)