re = /([0-9a-fA-F]{8})([0-9a-fA-F]{4})([0-9a-fA-F]{4})([0-9a-fA-F]{4})([0-9a-fA-F]+)/m
str = '0a1f0a1f0a1f0a1f0a1f0a1f0a1f 0a1f0a1f0a1f0a1f0a1f0a1f0a1f'
subst = '$1-$2-$3-$4-$5'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result