using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"cast[^\n]+\n[^\n]+\n[^\n]*datetime";
string input = @"cast('""
+ object.method()
+ ""' as datetime";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}