const regex = /cast[^\n]+\n[^\n]+\n[^\n]*datetime/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('cast[^\\n]+\\n[^\\n]+\\n[^\\n]*datetime', '')
const str = `cast('"
+ object.method()
+ "' as datetime`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}