re = /cast[^\n]+\n[^\n]+\n[^\n]*datetime/
str = 'cast(\'"
+ object.method()
+ "\' as datetime'
# Print the match result
str.match(re) do |match|
puts match.to_s
end