use strict;
my $str = '483.3731 EXP New trial (rep=0, index=1): {u\'selectPlayer\': 1, u\'neutralStim4\': u\'PSYCHOLOGIST\', u\'neutralStim2\': u\'PONG\', u\'neutralStim\': u\'YEN\', u\'positiveStim\': u\'PEACEFUL\', u\'neutralStim3\': u\'DASH\', u\'positiveStim3\': u\'HAPPY\', u\'positiveStim2\': u\'HONORABLE\', u\'negativeStim\': u\'BETRAYAL\', u\'negativeStim4\': u\'GUNPOINT\', u\'negativeStim3\': u\'JEALOUS\', u\'negativeStim2\': u\'MISTRUST\', u\'positiveStim4\': u\'AWESOME\'}';
my $regex = qr/\d+(?:\.\d+)?\s+EXP\s+New\strial\s\([^)]*\):\s+{[^}]+}/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}