re = /\d+(?:\.\d+)?\s+EXP\s+New\strial\s\([^)]*\):\s+{[^}]+}/
str = '483.3731 EXP New trial (rep=0, index=1): {u\'selectPlayer\': 1, u\'neutralStim4\': u\'PSYCHOLOGIST\', u\'neutralStim2\': u\'PONG\', u\'neutralStim\': u\'YEN\', u\'positiveStim\': u\'PEACEFUL\', u\'neutralStim3\': u\'DASH\', u\'positiveStim3\': u\'HAPPY\', u\'positiveStim2\': u\'HONORABLE\', u\'negativeStim\': u\'BETRAYAL\', u\'negativeStim4\': u\'GUNPOINT\', u\'negativeStim3\': u\'JEALOUS\', u\'negativeStim2\': u\'MISTRUST\', u\'positiveStim4\': u\'AWESOME\'}'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end