const regex = /\b(0*(25[0-5]|2[0-4]\d|[01]?\d\d?)\.){3}(0*(25[0-5]|2[0-4]\d|[01]?\d\d?))\b/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\b(0*(25[0-5]|2[0-4]\\d|[01]?\\d\\d?)\\.){3}(0*(25[0-5]|2[0-4]\\d|[01]?\\d\\d?))\\b', 'gm')
const str = `1.1.1.1
2.2.2.2
10.10.10.10
100.100.100.100
125.125.125.125
250.250.250.250
255.255.255.255
0101.0101.0101.0101
00000102.00000102.00000102.00000102
0.0.0.0
256.256.256.256
1234.1234.1234.1234
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}