import re
regex = re.compile(r"\b(0*(25[0-5]|2[0-4]\d|[01]?\d\d?)\.){3}(0*(25[0-5]|2[0-4]\d|[01]?\d\d?))\b", flags=re.MULTILINE)
test_str = ("1.1.1.1\n"
"2.2.2.2\n"
"10.10.10.10\n"
"100.100.100.100\n"
"125.125.125.125\n"
"250.250.250.250\n"
"255.255.255.255\n"
"0101.0101.0101.0101\n"
"00000102.00000102.00000102.00000102\n"
"0.0.0.0\n\n"
"256.256.256.256\n"
"1234.1234.1234.1234\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")