#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "\s*(?=.*[1-9])\d*(?:\.\d{1,2})?\s*"
Local $sString = "3" & @CRLF & _
"999" & @CRLF & _
"-3" & @CRLF & _
"0" & @CRLF & _
"0.0" & @CRLF & _
"1.0" & @CRLF & _
"0.1" & @CRLF & _
".01" & @CRLF & _
"-0.0000000000000000000000000000000001" & @CRLF & _
"2e3" & @CRLF & _
"-2e3" & @CRLF & _
"2e-3" & @CRLF & _
"-2e-3" & @CRLF & _
"1.0e0" & @CRLF & _
"0.1e1" & @CRLF & _
".01e-1" & @CRLF & _
"0.1" & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")