re = /\s*(?=.*[1-9])\d*(?:\.\d{1,2})?\s*/
str = '3
999
-3
0
0.0
1.0
0.1
.01
-0.0000000000000000000000000000000001
2e3
-2e3
2e-3
-2e-3
1.0e0
0.1e1
.01e-1
0.1
'
# Print the match result
str.match(re) do |match|
puts match.to_s
end