$re = '/class="(.*?)"/';
$str = 'bla<p class="c1 c2">blabla<button></button><div id="bla" class="c1 c3"></div>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);